[flutter] 플러터(flutter) 개발 환경 구성 방법

플러터(flutter)는 Google에서 개발한 모바일 애플리케이션 개발 프레임워크로, 하나의 코드베이스로 안드로이드와 iOS 모두를 지원합니다. 이번 포스트에서는 플러터를 개발하기 위한 환경 구성 방법에 대해 알아보겠습니다.

목차

Dart SDK 설치

플러터는 Dart 언어를 기반으로 작동합니다. 따라서, 먼저 Dart SDK를 설치해주어야 합니다.

  1. Dart SDK 공식 홈페이지에서 운영체제에 맞는 설치 파일을 다운로드합니다.
  2. 다운로드한 설치 파일을 실행하고, 설치 과정을 진행합니다. (Windows의 경우, 환경 변수에 Dart SDK 경로를 추가해주어야 합니다)

Flutter SDK 설치

플러터 SDK를 설치하기 위해서는 Git도 설치되어 있어야 합니다.

  1. Flutter SDK 공식 홈페이지에서 운영체제에 맞는 설치 파일을 다운로드합니다.
  2. 압축을 해제한 후, flutter 폴더를 임의의 위치에 이동시킵니다.
  3. 시스템 환경 변수에 flutter/bin 경로를 추가합니다.
  4. 명령 프롬프트를 열고, flutter doctor 명령어를 실행합니다. 설치된 패키지 및 개발 환경이 올바르게 설정되었는지 확인할 수 있습니다.

IDE(통합 개발 환경) 선택

플러터를 개발하기 위해서는 IDE가 필요합니다. 다음은 플러터 개발에 많이 사용되는 IDE들입니다.

모바일 개발 경험과 개인 선호도에 따라 IDE를 선택하면 됩니다. 선택한 IDE에서 Flutter와 Dart 플러그인을 설치하면 개발을 시작할 준비가 완료됩니다.

이제 개발 환경 구성이 완료되었으므로, Flutter 애플리케이션 개발에 도전해보세요!

참고 자료